求助:IE7和FireFox2解析错误的问题

刚才我遇到了一个很奇怪的问题,我尝试打开www.kenengba.com,发现浏览器(IE7)很快的出现无法打开的提示。我起初以为是服务器的问题,但打开同在服务器上的其它博客,没有问题。我觉得是浏览器的问题,用FF2打开www.kenengba.com,很快的,一片空白,查看源代码也是一片空白。

因为是“立即”反应的无法打开,所有不是连接超时的问题。

我觉得可能是DNS的问题,但ping返回的地址是服务器正确的IP。

然后我试试分别用IE7和FF打开kenengba.com,也就是没有www,可以打开。

我再ping一下kenengba.com,返回的IP和www.kenengba.com是一样的。

我觉得很奇怪,但还是觉得是DNS的问题,我将DNS切换到OpenDNS,问题依旧。我在hosts里将www.kenengba.com与服务器的IP绑定,还是上不去。

我以为是自己电脑的问题,但发现我旁边两位朋友的IE7也打不开含有www的可能吧。

如果这是IE的问题,为什么FF也无法打开呢?

我请求其它地区的朋友用IE7尝试,没有问题,可以打开。

因此问题肯定出现在我这里的网络,但问题在哪呢?

然后我试了一下旁边另外一个朋友的IE6,晕,可以打开含有www的可能吧。然后我再试一下我电脑上的Safari,也可以打开,但IE7和FF2依然无法打开。

如果说这是我电脑上的IE7和FF的DNS缓存错误的问题,为什么我旁边电脑的IE7也同样有问题呢?

有没有朋友能告诉我,到底问题出在哪里呢?

18 条评论

  1. 2008 年 4 月 11 日 下午 4:12

    估计还是网络的原因,我也遇到过同样的情况,每天都要重新刷新一下才行。

  2. 张杨
    2008 年 4 月 11 日 下午 4:59

    不知道

  3. 2008 年 4 月 11 日 下午 5:10

    曾经有一段时间,我用Opera和IE7无法打开可能吧,IE6可以。

  4. 2008 年 4 月 11 日 下午 5:22

    , 很奇怪的现象。
    我这里打开着正常着,

  5. overwhelming
    2008 年 4 月 11 日 下午 5:56

    学习博主处理问题的思路

  6. 2008 年 4 月 11 日 下午 7:58

    WWW,必须吗。我就不喜欢输入这些
    http://www,这一段我都不想要
    但现在大多数网站都要这个了
    更气人的是,有些网站在申请了.CN后,
    在本来就长的网址上加了.CN。变成.COM.CN。烦啊
    博主这样不用WWW.不是更省事了吗

    • 2008 年 4 月 11 日 下午 10:44

      你将文中的kenengba.com替换为www.kenengba.com,www.kenengba.com替换为kenengba.com,就会明白我这篇文章的意思。

  7. Roar
    2008 年 4 月 11 日 下午 9:53

    你打www.kenengba.com.试试。后面是加一个.

    把Internet选项的设置设为恢复默认值再试试。

  8. Crend KIng
    2008 年 4 月 12 日 上午 4:08

    我用FF2,有时也有这个问题,不单是某一个网站的问题。怀疑是FF2本身的问题。

  9. 大西国
    2008 年 4 月 12 日 上午 9:19

    FF3正常

  10. 2008 年 4 月 12 日 上午 10:01

    我这里www和non-www 都可以访问。
    ps:虽然问题已经解决,不过建议Jason把两个域名统一一下,做一个跳转

  11. 2008 年 4 月 13 日 下午 4:09

    FF高级-网络-连接 里是否设置了代理服务器或者连接方式是否有变化?是否设置了本地连接?

  12. 2008 年 4 月 13 日 下午 5:07

    我也试过,墙内的线路似乎会检查某些域名的内容,而到了繁忙时间(不一定是中国的繁忙时间),这个系统便会 block 。

    block还好,有时它还会循环重定向, 这时候看文件头可以发现,浏览器其实已经访问了一个莫名其妙的地址。奇怪的是IE6没有这个问题,但有一些跳转代码也只有在IE6里才能运行。

    这种问题遇到过几次了,特别是那些有敏感内容,但又不至于被G F的网址。我只能说,这样的烂系统,也许是临时工干的。

    • 2008 年 4 月 13 日 下午 6:34

      我觉得这个和GF关系不大吧?因为响应的速度很快,就像本地DNS无法解析一样,瞬时无法连接。
      不过现在问题不再出现了。

  13. everack
    2008 年 4 月 14 日 上午 8:52

    我用opendns,刚用IE7和FF2试过,2个都没有问题。在想可能是电脑或者网络的问题。

  14. bigtfoot
    2008 年 5 月 18 日 上午 9:39

    可能是网页编码的问题,我访问 portableapps.com 时候也经常出现这种 一片空白的问题。
    只要把编码选择为 UTF8就好了

发表评论

电子邮件地址不会被公开。 必填项已用*标注